Package Search Help

You can use boolean logic (e.g. AND/OR/NOT) for complex search queries. For more help and examples, see the search documentation.

Search by package name:
my-package (implicit)
name:my-package (explicit)

Search by package filename:
my-package.ext (implicit)
filename:my-package.ext (explicit)

Search by package tag:
latest (implicit)
tag:latest (explicit)

Search by package version:
1.0.0 (implicit)
version:1.0.0 (explicit)
prerelease:true (prereleases)
prerelease:false (no prereleases)

Search by package architecture:
architecture:x86_64 

Search by package distribution:
distribution:el 

Search by package license:
license:MIT 

Search by package format:
format:deb 

Search by package status:
status:in_progress 

Search by package file checksum:
checksum:5afba 

Search by package security status:
severity:critical 

Search by package vulnerabilities:
vulnerabilities:>1 
vulnerabilities:<1000 

Search by package downloads:
downloads:>8 
downloads:<100 

Search by package type:
type:binary 
type:source 

Search by package size (bytes):
size:>50000 
size:<10000 

Search by dependency name:
dependency:log4j 

Search by uploaded date:
uploaded:>"1 day ago" 
uploaded:<"August 14, 2018 EST" 

Search by entitlement token (identifier):
entitlement:3lKPVJPosCsY 

Search queries for all Maven-specific (and related) package types

Search by group ID:
maven_group_id:org.apache 

Field type modifiers (depending on the type, you can influence behaviour)

For all queries, you can use:
~foo for negation

For string queries, you can use:
^foo to anchor to start of term
foo$ to anchor to end of term
foo*bar for fuzzy matching

For number/date queries, you can use:
>foo for values greater than
>=foo for values greater / equal
<foo for values less than
<=foo for values less / equal

Need a secure and centralised artifact repository to deliver Alpine, Cargo, CocoaPods, Composer, Conan, Conda, CRAN, Dart, Debian, Docker, Go, Helm, LuaRocks, Maven, npm, NuGet, P2, Python, RedHat, Ruby, Terraform, Vagrant, Raw & More packages?

Cloudsmith is the new standard in Package / Artifact Management and Software Distribution.

With support for all major package formats, you can trust us to manage your software supply chain.

Start My Free Trial
 Public spatialos spatialos / gdk-for-unity
GDK for Unity: NPM packages to be used with the SpatialOS GDK for Unity

npm logo io.improbable.worker.sdk  14.0.2

One-liner (summary)

No summary - See description for more info.

Description

SpatialOS Worker SDK.

License

Unknown

Size

24.2 MB

Downloads

679

Tags

npm tgz

Status  Completed
Checksum (MD5) 45c37f1b4436544a3fb3509dadda13c7
Checksum (SHA-1) 84ae4a68933008e75cb756bd3d98c768bd11e261
Checksum (SHA-256) d9ad9e010ab6c0761066a30350dfd91be91a7e108256b9a1885b21ce73a4a987
Checksum (SHA-512) f2cc633fc14dbd1dd8b77aff47669aa91f5b9d80f565c389fab06501d7b433c59a…
GPG Signature
Storage Region Default Region
Type  Source (contains source code or documentation)
Uploaded At 2 years, 11 months ago
Uploaded By gdk-for-unity-bot-dogbot
Slug Id ioimprobableworkersdk-1402tgz
Unique Id u9gS6JIavqsi
Version (Raw) 14.0.2
Version (Parsed)
  • Major: 14
  • Minor: 0
  • Patch: 2
  • Type: SemVer (Strict)
  extended metadata
Package 100% Valid
pkg io.improbable.worker.sdk-14.0.2… 679
24.2 MB
md5 sha1 sha256 sha512
Package Contents (io.improbable.worker.sdk-14.0.2.tgz)
Loading...

This package has 53 files/directories.

Security Scanning:
You can't see this because the plan doesn't include this feature, sorry!

With Security Scanning, Cloudsmith will scan your artefacts for vulnerabilities when they're uploaded. These are then presented to you via the UI and the API, so that you can build rules into your CI/CD pipelines to decide how to handle low, medium, high and critical software vulnerabilities.

If you'd like to trial or ask about the Security Scanning feature, just ask us. We'll be happy to help!

Last scanned

1 week, 1 day ago

Scan result

Vulnerable

Vulnerability count

3

Max. severity

Critical
Target:
CRITICAL

CVE-6638-47300: library: vulnerability title



Package Name: package_name
Installed Version: 1.1.65
Fixed Version: 2.5.100

References: www.gomez.biz morrow.com mccann.com
CRITICAL

CVE-5269-12029: library: vulnerability title



Package Name: package_name
Installed Version: 1.9.89
Fixed Version: 2.2.86

References: matthews.biz www.perez.com reynolds-johnston.com
MEDIUM

CVE-3117-66069: library: vulnerability title



Package Name: package_name
Installed Version: 1.7.27
Fixed Version: 2.7.53

References: www.murray-fowler.com santiago.net holt.com
Loading...

You can embed a badge in another website that shows this or the latest version of this package.

To embed the badge for this specific package version, use the following:

[![This version of 'io.improbable.worker.sdk' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/14.0.2/x/?render=true)](https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/14.0.2/)
|This version of 'io.improbable.worker.sdk' @ Cloudsmith|
.. |This version of 'io.improbable.worker.sdk' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/14.0.2/x/?render=true
   :target: https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/14.0.2/
image::https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/14.0.2/x/?render=true[link="https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/14.0.2/",title="This version of 'io.improbable.worker.sdk' @ Cloudsmith"]
<a href="https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/14.0.2/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/14.0.2/x/?render=true" alt="This version of 'io.improbable.worker.sdk' @ Cloudsmith" /></a>

rendered as: This version of 'io.improbable.worker.sdk' @ Cloudsmith

To embed the badge for the latest package version, use the following:

[![Latest version of 'io.improbable.worker.sdk' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/latest/x/?render=true&show_latest=true)](https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/latest/)
|Latest version of 'io.improbable.worker.sdk' @ Cloudsmith|
.. |Latest version of 'io.improbable.worker.sdk' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/latest/x/?render=true&show_latest=true
   :target: https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/latest/
image::https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/latest/x/?render=true&show_latest=true[link="https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/latest/",title="Latest version of 'io.improbable.worker.sdk' @ Cloudsmith"]
<a href="https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/latest/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/latest/x/?render=true&show_latest=true" alt="Latest version of 'io.improbable.worker.sdk' @ Cloudsmith" /></a>

rendered as: Latest version of 'io.improbable.worker.sdk' @ Cloudsmith

These instructions assume you have setup the repository first (or read it).

To install/use io.improbable.worker.sdk @ version 14.0.2 ...

npm install 'io.improbable.worker.sdk@14.0.2'

You can also install the latest version of this package:

npm install 'io.improbable.worker.sdk'

If necessary, you can specify the registry directly:

npm install \
  --registry=https://npm.improbable.io/gdk-for-unity/ \
  'io.improbable.worker.sdk@14.0.2'

Alternatively, you can add it to dependencies in your project package.json file:

{ "dependencies": { "io.improbable.worker.sdk": "14.0.2" } }

If you're using yarn, you need to add always-auth to your user or project .npmrc:

always-auth
Warning: We highly recommend using npm dependencies in your own project rather than installing directly.
Top