Package Search Help

You can use boolean logic (e.g. AND/OR/NOT) for complex search queries. For more help and examples, see the search documentation.

Search by package name:
my-package (implicit)
name:my-package (explicit)

Search by package filename:
my-package.ext (implicit)
filename:my-package.ext (explicit)

Search by package tag:
latest (implicit)
tag:latest (explicit)

Search by package version:
1.0.0 (implicit)
version:1.0.0 (explicit)
prerelease:true (prereleases)
prerelease:false (no prereleases)

Search by package architecture:
architecture:x86_64 

Search by package distribution:
distribution:el 

Search by package license:
license:MIT 

Search by package format:
format:deb 

Search by package status:
status:in_progress 

Search by package file checksum:
checksum:5afba 

Search by package security status:
severity:critical 

Search by package vulnerabilities:
vulnerabilities:>1 
vulnerabilities:<1000 

Search by package downloads:
downloads:>8 
downloads:<100 

Search by package type:
type:binary 
type:source 

Search by package size (bytes):
size:>50000 
size:<10000 

Search by dependency name:
dependency:log4j 

Search by uploaded date:
uploaded:>"1 day ago" 
uploaded:<"August 14, 2018 EST" 

Search by entitlement token (identifier):
entitlement:3lKPVJPosCsY 

Search queries for all Maven-specific (and related) package types

Search by group ID:
maven_group_id:org.apache 

Field type modifiers (depending on the type, you can influence behaviour)

For all queries, you can use:
~foo for negation

For string queries, you can use:
^foo to anchor to start of term
foo$ to anchor to end of term
foo*bar for fuzzy matching

For number/date queries, you can use:
>foo for values greater than
>=foo for values greater / equal
<foo for values less than
<=foo for values less / equal

Need a secure and centralised artifact repository to deliver Alpine, Cargo, CocoaPods, Composer, Conan, Conda, CRAN, Dart, Debian, Docker, Go, Helm, LuaRocks, Maven, npm, NuGet, P2, Python, RedHat, Ruby, Terraform, Vagrant, Raw & More packages?

Cloudsmith is the new standard in Package / Artifact Management and Software Distribution.

With support for all major package formats, you can trust us to manage your software supply chain.

Start My Free Trial
 Public spatialos spatialos / gdk-for-unity
GDK for Unity: NPM packages to be used with the SpatialOS GDK for Unity

npm logo io.improbable.worker.sdk  13.8.2

One-liner (summary)

No summary - See description for more info.

Description

SpatialOS Worker SDK.

License

Unknown

Size

8.3 MB

Downloads

294

Tags

npm tgz

Status  Completed
Checksum (MD5) 8c9dc04b9223e8e132545d6d792fca06
Checksum (SHA-1) 6d789450bcf60e22b5fba4964624ffef9804fc5e
Checksum (SHA-256) 5cf636d203bad5b03e2382b57e836c8805a8b878e7e13dde57be23b2e8f0d5a4
Checksum (SHA-512) b70aeece7abe3bb476f8852c87010276d9fe39aeec508347e1d18bf42cb4657de4…
GPG Signature
Storage Region Default Region
Type  Source (contains source code or documentation)
Uploaded At 3 years, 4 months ago
Uploaded By Fetched by Cloudsmith
Slug Id ioimprobableworkersdk-1382tgz
Unique Id s8MtChzCu1QF
Version (Raw) 13.8.2
Version (Parsed)
  • Major: 13
  • Minor: 8
  • Patch: 2
  • Type: SemVer (Strict)
  extended metadata
Package 100% Valid
pkg io.improbable.worker.sdk-13.8.2… 294
8.3 MB
md5 sha1 sha256 sha512
Package Contents (io.improbable.worker.sdk-13.8.2.tgz)
Loading...

This package has 51 files/directories.

Security Scanning:
You can't see this because your subscription doesn't include this feature, sorry!

With Security Scanning, Cloudsmith will scan your artefacts for vulnerabilities when they're uploaded. These are then presented to you via the UI and the API, so that you can build rules into your CI/CD pipelines to decide how to handle low, medium, high and critical software vulnerabilities.

If you'd like to trial or ask about the Security Scanning feature, just ask us. We'll be happy to help!

Last scanned

1 week ago

Scan result

Vulnerable

Vulnerability count

4

Max. severity

Critical
Target:
HIGH

CVE-8497-79393: library: vulnerability title



Package Name: package_name
Installed Version: 1.5.4
Fixed Version: 2.10.42

References: gates-brown.com www.johnson.com www.foster-miller.com
MEDIUM

CVE-3171-59607: library: vulnerability title



Package Name: package_name
Installed Version: 1.2.22
Fixed Version: 2.9.72

References: flores-thornton.biz robinson.biz torres-hays.com
LOW

CVE-9668-39340: library: vulnerability title



Package Name: package_name
Installed Version: 1.5.81
Fixed Version: 2.6.4

References: www.chandler-wang.biz cooke-chan.com dunlap-patel.org
LOW

CVE-6996-60984: library: vulnerability title



Package Name: package_name
Installed Version: 1.4.58
Fixed Version: 2.5.64

References: ford.com cannon.net www.johnson.com

You can embed a badge in another website that shows this or the latest version of this package.

To embed the badge for this specific package version, use the following:

[![This version of 'io.improbable.worker.sdk' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/13.8.2/x/?render=true)](https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/13.8.2/)
|This version of 'io.improbable.worker.sdk' @ Cloudsmith|
.. |This version of 'io.improbable.worker.sdk' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/13.8.2/x/?render=true
   :target: https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/13.8.2/
image::https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/13.8.2/x/?render=true[link="https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/13.8.2/",title="This version of 'io.improbable.worker.sdk' @ Cloudsmith"]
<a href="https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/13.8.2/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/13.8.2/x/?render=true" alt="This version of 'io.improbable.worker.sdk' @ Cloudsmith" /></a>

rendered as: This version of 'io.improbable.worker.sdk' @ Cloudsmith

To embed the badge for the latest package version, use the following:

[![Latest version of 'io.improbable.worker.sdk' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/latest/x/?render=true&show_latest=true)](https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/latest/)
|Latest version of 'io.improbable.worker.sdk' @ Cloudsmith|
.. |Latest version of 'io.improbable.worker.sdk' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/latest/x/?render=true&show_latest=true
   :target: https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/latest/
image::https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/latest/x/?render=true&show_latest=true[link="https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/latest/",title="Latest version of 'io.improbable.worker.sdk' @ Cloudsmith"]
<a href="https://cloudsmith.io/~spatialos/repos/gdk-for-unity/packages/detail/npm/io.improbable.worker.sdk/latest/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/spatialos/gdk-for-unity/npm/io.improbable.worker.sdk/latest/x/?render=true&show_latest=true" alt="Latest version of 'io.improbable.worker.sdk' @ Cloudsmith" /></a>

rendered as: Latest version of 'io.improbable.worker.sdk' @ Cloudsmith

These instructions assume you have setup the repository first (or read it).

To install/use io.improbable.worker.sdk @ version 13.8.2 ...

npm install 'io.improbable.worker.sdk@13.8.2'

You can also install the latest version of this package:

npm install 'io.improbable.worker.sdk'

If necessary, you can specify the registry directly:

npm install \
  --registry=https://npm.improbable.io/gdk-for-unity/ \
  'io.improbable.worker.sdk@13.8.2'

Alternatively, you can add it to dependencies in your project package.json file:

{ "dependencies": { "io.improbable.worker.sdk": "13.8.2" } }

If you're using yarn, you need to add always-auth to your user or project .npmrc:

always-auth
Warning: We highly recommend using npm dependencies in your own project rather than installing directly.
Top