Need your own package repository for Alpine, Cargo, CocoaPods, Composer, Conan, Conda, CRAN, Dart, Debian, Docker, Go, Helm, LuaRocks, Maven, npm, NuGet, P2, Python, RedHat, Ruby, Terraform, Vagrant, Raw & More?

Cloudsmith provides better DevOps with simple and secure delivery of your software, from dev to production.

Start My Free Trial
Package Search Help

You can use boolean logic (e.g. AND/OR/NOT) for complex search queries. For more help and examples, see the search documentation.

Search by package name:
my-package (implicit)
name:my-package (explicit)

Search by package filename:
my-package.ext (implicit)
filename:my-package.ext (explicit)

Search by package tag:
latest (implicit)
tag:latest (explicit)

Search by package version:
1.0.0 (implicit)
version:1.0.0 (explicit)
prerelease:true (prereleases)
prerelease:false (no prereleases)

Search by package architecture:
architecture:x86_64 

Search by package distribution:
distribution:el 

Search by package license:
license:MIT 

Search by package format:
format:deb 

Search by package status:
status:in_progress 

Search by package file checksum:
checksum:5afba 

Search by package security status:
severity:critical 

Search by package vulnerabilities:
vulnerabilities:>1 
vulnerabilities:<1000 

Search by package downloads:
downloads:>8 
downloads:<100 

Search by package type:
type:binary 
type:source 

Search by package size (bytes):
size:>50000 
size:<10000 

Search by dependency name:
dependency:log4j 

Search by uploaded date:
uploaded:>"1 day ago" 
uploaded:<"August 14, 2018 EST" 

Search by entitlement token (identifier):
entitlement:3lKPVJPosCsY 

Search queries for all Maven-specific (and related) package types

Search by group ID:
maven_group_id:org.apache 

Field type modifiers (depending on the type, you can influence behaviour)

For all queries, you can use:
~foo for negation

For string queries, you can use:
^foo to anchor to start of term
foo$ to anchor to end of term
foo*bar for fuzzy matching

For number/date queries, you can use:
>foo for values greater than
>=foo for values greater / equal
<foo for values less than
<=foo for values less / equal

 Public consensys consensys (ConsenSys) / maven
maven-public: Public maven repository

Maven logo web3j-sumo  0.1.6

One-liner (summary)

net.consensys:web3j-sumo:0.1.6

Description

No description - See summary for more info.

License

Unknown

Size

409.5 KB

Downloads

0

Status  Completed
Checksum (MD5) ca1aca8ee7adf936c59412b705169aa4
Checksum (SHA-1) febd402d62e69b0f51d22b73552d45b6ac1dfebe
Checksum (SHA-256) 03902945a8e583a4572d473ada9efa06efff8b12cd806a9a0739daa9faed992c
Checksum (SHA-512) c5e3f679adcf78985fe927e05433e177f8984d7cd41239246b3743e34a37fb2977…
GPG Signature
Storage Region Default Region
Type  Binary (contains binaries and binary artifacts)
Uploaded At 5 days, 1 hour ago
Uploaded By cs-ops
Slug Id w7SZZ8QTE9kj-QBl
Unique Id LyWmgzwFfMIl
Version (Raw) 0.1.6
Version (Parsed)
  • Major: 0
  • Minor: 1
  • Patch: 6
  • Type: SemVer (Strict)
  extended metadata
Artifact Id web3j-sumo
Group Id net.consensys
Is Snapshot
Packaging jar
  dependencies
Checksum (MD5) f3b91f08866b097b2c6d3c39fcaa5c01
Runtime commons-codec:commons-codec >= 1.15 | org.apache.logging.log4j:log4j-api >= 2.16.0 | org.apache.logging.log4j:log4j-core >= 2.16.0 | org.javatuples:javatuples >= 1.2
Compile org.jetbrains.kotlin:kotlin-stdlib-jdk8 >= 1.6.10 | org.web3j:core >= 4.9.2
pkg web3j-sumo-0.1.6.jar 0
98.4 KB
md5 sha1 sha256 sha512
pkg web3j-sumo-0.1.6-javadoc.jar 0
309.6 KB
md5 sha1 sha256 sha512
pom web3j-sumo-0.1.6.pom 0
1.5 KB
md5 sha1 sha256 sha512
Package Contents (web3j-sumo-0.1.6.jar)
Loading...

This package has 86 files/directories.

 Newer Maven logo
web3j-sumo
1 cs-ops
 Newer Maven logo
web3j-sumo
0 cs-ops
 Newer Maven logo
web3j-sumo
0 cs-ops
 Newer Maven logo
web3j-sumo
0 cs-ops
 Newer Maven logo
web3j-sumo
 0.29.4
3 cs-ops
 Newer Maven logo
web3j-sumo
 0.29.3
9.4 MB 2 months ago
25 cs-ops
 Newer Maven logo
web3j-sumo
 0.29.2
9.4 MB 2 months ago
4 cs-ops
 Newer Maven logo
web3j-sumo
 0.29.1
9.4 MB 2 months ago
3 cs-ops
 Newer Maven logo
web3j-sumo
 0.28.0
9.8 MB 5 months ago
1501 cs-ops
 Newer Maven logo
web3j-sumo
9.8 MB 5 months ago
15 cs-ops
 Newer Maven logo
web3j-sumo
 0.27.1
1281 cs-ops
 Newer Maven logo
web3j-sumo
 0.27.0
43 cs-ops
 Newer Maven logo
web3j-sumo
 0.26.3
10.6 MB 7 months ago
215 cs-ops
 Newer Maven logo
web3j-sumo
13 cs-ops
 Newer Maven logo
web3j-sumo
 0.26.2
441 cs-ops
 Newer Maven logo
web3j-sumo
 0.26.0
125 cs-ops
 Newer Maven logo
web3j-sumo
 0.24.0
5.2 MB 8 months ago
241 cs-ops
  Maven logo
web3j-sumo
 0.1.6
0 cs-ops
 Newer Maven logo
web3j-sumo
3 cs-ops
 Older Maven logo
web3j-sumo
 0.1.1
0 cs-ops
Loading...

You can embed a badge in another website that shows this or the latest version of this package.

To embed the badge for this specific package version, use the following:

[![This version of 'web3j-sumo' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/web3j-sumo/0.1.6/a=noarch;xg=net.consensys/?render=true)](https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/web3j-sumo/0.1.6/a=noarch;xg=net.consensys/)
|This version of 'web3j-sumo' @ Cloudsmith|
.. |This version of 'web3j-sumo' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/web3j-sumo/0.1.6/a=noarch;xg=net.consensys/?render=true
   :target: https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/web3j-sumo/0.1.6/a=noarch;xg=net.consensys/
image::https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/web3j-sumo/0.1.6/a=noarch;xg=net.consensys/?render=true[link="https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/web3j-sumo/0.1.6/a=noarch;xg=net.consensys/",title="This version of 'web3j-sumo' @ Cloudsmith"]
<a href="https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/web3j-sumo/0.1.6/a=noarch;xg=net.consensys/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/web3j-sumo/0.1.6/a=noarch;xg=net.consensys/?render=true" alt="This version of 'web3j-sumo' @ Cloudsmith" /></a>

rendered as: This version of 'web3j-sumo' @ Cloudsmith

To embed the badge for the latest package version, use the following:

[![Latest version of 'web3j-sumo' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/web3j-sumo/latest/a=noarch;xg=net.consensys/?render=true&show_latest=true)](https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/web3j-sumo/latest/a=noarch;xg=net.consensys/)
|Latest version of 'web3j-sumo' @ Cloudsmith|
.. |Latest version of 'web3j-sumo' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/web3j-sumo/latest/a=noarch;xg=net.consensys/?render=true&show_latest=true
   :target: https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/web3j-sumo/latest/a=noarch;xg=net.consensys/
image::https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/web3j-sumo/latest/a=noarch;xg=net.consensys/?render=true&show_latest=true[link="https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/web3j-sumo/latest/a=noarch;xg=net.consensys/",title="Latest version of 'web3j-sumo' @ Cloudsmith"]
<a href="https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/web3j-sumo/latest/a=noarch;xg=net.consensys/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/web3j-sumo/latest/a=noarch;xg=net.consensys/?render=true&show_latest=true" alt="Latest version of 'web3j-sumo' @ Cloudsmith" /></a>

rendered as: Latest version of 'web3j-sumo' @ Cloudsmith

These instructions assume you have setup the repository first (or read it).

To install/use web3j-sumo @ version 0.1.6 ...

Then you can then depend on web3j-sumo @ version 0.1.6, via:

Add the following to your project pom.xml file:

<dependency>
  <groupId>net.consensys</groupId>
  <artifactId>web3j-sumo</artifactId>
  <version>0.1.6</version>
</dependency>
dependencies {
  implementation 'net.consensys:web3j-sumo:0.1.6'
}

Note: These examples use the Groovy-based syntax for Gradle. For the Kotlin syntax, please refer to the official documentation for declaring dependencies.

Add the following to your project build.sbt file:

libraryDependencies += "net.consensys" % "web3j-sumo" % "0.1.6"

Add the following to your project project.clj file:

:dependencies [[net.consensys/web3j-sumo "0.1.6"]]

For other build systems, such as grape, please consult your build system documentation for more help.

Top