Need your own package repository for Alpine, Cargo, CocoaPods, Composer, Conan, CRAN, Dart, Debian, Docker, Go, Helm, LuaRocks, Maven, npm, NuGet, Python, RedHat, Ruby, Terraform, Vagrant, Raw & More?

Cloudsmith provides better DevOps with simple and secure delivery of your software, from dev to production.

Start My Free 7-Day Trial
 Public consensys consensys (ConsenSys) / maven
maven-public: Public maven repository

Maven logo orion  21.1.1

One-liner (summary)

net.consensys:orion:21.1.1

Description

A java implementation of an Enterprise Ethereum Private Transaction Manager.

Size

969.2 KB

Downloads

1784

Status  Completed
Checksum (MD5) b6712610a9c3db2b8c3932010c247aef
Checksum (SHA-1) e1ca8e18ac87940b4e6179216738ce79a24ecf71
Checksum (SHA-256) bab35792609a2d33d004da198cf0dc1e93b2961b60f52a7a7fe00da41363b3d1
Checksum (SHA-512) 09d74d8b1288c2bf2f3df51905b2aa3e1eac73ee6d9609f9b707367644d972ef37…
GPG Signature
Storage Region Default Region
Type  Binary (contains binaries and binary artifacts)
Uploaded At 6 months, 2 weeks ago
Uploaded By cs-ops
Slug Id 664eEEHUogNq-2ea
Unique Id W997cSa8Qtai
Version (Raw) 21.1.1
Version (Parsed)
  • Major: 21
  • Minor: 1
  • Patch: 1
  • Type: SemVer (Strict)
  extended metadata
Artifact Id orion
Group Id net.consensys
Is Snapshot
Packaging jar
Url https://github.com/consensys/orion
  dependencies
Checksum (MD5) e6e14ef8dd334aeaac28691e60f6a48c
Runtime org.antlr:antlr4-runtime >= None | org.jetbrains.kotlinx:kotlinx-coroutines-core >= None
Compile com.fasterxml.jackson.core:jackson-databind >= None | com.fasterxml.jackson.dataformat:jackson-dataformat-cbor >= None | com.fasterxml.jackson.datatype:jackson-datatype-jdk8 >= None | com.github.jnr:jnr-ffi >= None | com.jolbox:bonecp >= None | com.moandjiezana.toml:toml4j >= None | com.oracle.ojdbc:ojdbc10 >= None | io.vertx:vertx-core >= None | io.vertx:vertx-web >= None | javax.xml.bind:jaxb-api >= None | org.apache.logging.log4j:log4j-api >= None | org.apache.logging.log4j:log4j-core >= None | org.apache.logging.log4j:log4j-slf4j-impl >= None | org.apache.openjpa:openjpa >= None | org.apache.tuweni:bytes >= None | org.apache.tuweni:concurrent >= None | org.apache.tuweni:concurrent-coroutines >= None | org.apache.tuweni:config >= None | org.apache.tuweni:crypto >= None | org.apache.tuweni:io >= None | org.apache.tuweni:kv >= None | org.apache.tuweni:net >= None | org.apache.tuweni:rlp >= None | org.apache.tuweni:toml >= None | org.bouncycastle:bcpkix-jdk15on >= None | org.bouncycastle:bcprov-jdk15on >= None | org.fusesource.leveldbjni:leveldbjni-all >= None | org.lz4:lz4-java >= None | org.mapdb:mapdb >= None | org.postgresql:postgresql >= None
Excluded net.jpountz.lz4:lz4 = all
pkg orion-21.1.1.jar 1784
161.9 KB
md5 sha1 sha256 sha512
javadoc orion-21.1.1-javadoc.jar 1
688.0 KB
md5 sha1 sha256 sha512
pom orion-21.1.1.pom 1786
14.3 KB
md5 sha1 sha256 sha512
sources orion-21.1.1-sources.jar 374
104.9 KB
md5 sha1 sha256 sha512
Package Contents (orion-21.1.1.jar)
Loading...

This package has 112 files/directories.

Loading...

You can embed a badge in another website that shows this or the latest version of this package.

To embed the badge for this specific package version, use the following:

[![This version of 'orion' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/orion/21.1.1/a=noarch;xg=net.consensys/?render=true)](https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/orion/21.1.1/a=noarch;xg=net.consensys/)
|This version of 'orion' @ Cloudsmith|
.. |This version of 'orion' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/orion/21.1.1/a=noarch;xg=net.consensys/?render=true
   :target: https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/orion/21.1.1/a=noarch;xg=net.consensys/
image::https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/orion/21.1.1/a=noarch;xg=net.consensys/?render=true[link="https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/orion/21.1.1/a=noarch;xg=net.consensys/",title="This version of 'orion' @ Cloudsmith"]
<a href="https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/orion/21.1.1/a=noarch;xg=net.consensys/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/orion/21.1.1/a=noarch;xg=net.consensys/?render=true" alt="This version of 'orion' @ Cloudsmith" /></a>

rendered as: This version of 'orion' @ Cloudsmith

To embed the badge for the latest package version, use the following:

[![Latest version of 'orion' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/orion/latest/a=noarch;xg=net.consensys/?render=true&show_latest=true)](https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/orion/latest/a=noarch;xg=net.consensys/)
|Latest version of 'orion' @ Cloudsmith|
.. |Latest version of 'orion' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/orion/latest/a=noarch;xg=net.consensys/?render=true&show_latest=true
   :target: https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/orion/latest/a=noarch;xg=net.consensys/
image::https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/orion/latest/a=noarch;xg=net.consensys/?render=true&show_latest=true[link="https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/orion/latest/a=noarch;xg=net.consensys/",title="Latest version of 'orion' @ Cloudsmith"]
<a href="https://cloudsmith.io/~consensys/repos/maven/packages/detail/maven/orion/latest/a=noarch;xg=net.consensys/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/consensys/maven/maven/orion/latest/a=noarch;xg=net.consensys/?render=true&show_latest=true" alt="Latest version of 'orion' @ Cloudsmith" /></a>

rendered as: Latest version of 'orion' @ Cloudsmith

These instructions assume you have setup the repository first (or read it).

To install/use orion @ version 21.1.1 ...

Then you can then depend on orion @ version 21.1.1, via:

Add the following to your project pom.xml file:

<dependency>
  <groupId>net.consensys</groupId>
  <artifactId>orion</artifactId>
  <version>21.1.1</version>
</dependency>
dependencies {
  implementation 'net.consensys:orion:21.1.1'
}

Note: These examples use the Groovy-based syntax for Gradle. For the Kotlin syntax, please refer to the official documentation for declaring dependencies.

Add the following to your project build.sbt file:

libraryDependencies += "net.consensys" % "orion" % "21.1.1"

Add the following to your project project.clj file:

:dependencies [[net.consensys/orion "21.1.1"]]

For other build systems, such as grape, please consult your build system documentation for more help.

Prev Version
Next Version
Top