Package Search Help

You can use boolean logic (e.g. AND/OR/NOT) for complex search queries. For more help and examples, see the search documentation.

Search by package name:
my-package (implicit)
name:my-package (explicit)

Search by package filename:
my-package.ext (implicit)
filename:my-package.ext (explicit)

Search by package tag:
latest (implicit)
tag:latest (explicit)

Search by package version:
1.0.0 (implicit)
version:1.0.0 (explicit)
prerelease:true (prereleases)
prerelease:false (no prereleases)

Search by package architecture:
architecture:x86_64 

Search by package distribution:
distribution:el 

Search by package license:
license:MIT 

Search by package format:
format:deb 

Search by package status:
status:in_progress 

Search by package file checksum:
checksum:5afba 

Search by package security status:
severity:critical 

Search by package vulnerabilities:
vulnerabilities:>1 
vulnerabilities:<1000 

Search by # of package downloads:
downloads:>8 
downloads:<100 

Search by package type:
type:binary 
type:source 

Search by package size (bytes):
size:>50000 
size:<10000 

Search by dependency name/version:
dependency:log4j 
dependency:log4j=1.0.0 
dependency:log4j>1.0.0 

Search by uploaded date:
uploaded:>"1 day ago" 
uploaded:<"August 14, 2022 EST" 

Search by entitlement token (identifier):
entitlement:3lKPVJPosCsY 

Search by policy violation:
policy_violated:true
deny_policy_violated:true
license_policy_violated:true
vulnerability_policy_violated:true

Search by repository:
repository:repo-name

Search queries for all Debian-specific (and related) package types

Search by component:
deb_component:unstable

Search queries for all Maven-specific (and related) package types

Search by group ID:
maven_group_id:org.apache

Search queries for all Docker-specific (and related) package types

Search by image digest:
docker_image_digest:sha256:7c5..6d4
(full hashref only)

Search by layer digest:
docker_layer_digest:sha256:4c4..ae4
(full hashref only)

Field type modifiers (depending on the type, you can influence behaviour)

For all queries, you can use:
~foo for negation

For string queries, you can use:
^foo to anchor to start of term
foo$ to anchor to end of term
foo*bar for fuzzy matching

For number/date or version queries, you can use:
>foo for values greater than
>=foo for values greater / equal
<foo for values less than
<=foo for values less / equal

Need a secure and centralised artifact repository to deliver Alpine, Cargo, CocoaPods, Composer, Conan, Conda, CRAN, Dart, Debian, Docker, Go, Helm, Hex, LuaRocks, Maven, npm, NuGet, P2, Python, RedHat, Ruby, Swift, Terraform, Vagrant, Raw & More packages?

Cloudsmith is the new standard in Package / Artifact Management and Software Distribution.

With support for all major package formats, you can trust us to manage your software supply chain.

Start My Free Trial
 Open-Source typedb typedb (TypeDB) / public-release  GitHub Project
public: A certifiably-awesome open-source package repository curated by TypeDB, hosted by Cloudsmith.
Note: Packages in this repository are licensed as GNU Affero General Public License v3.0 (dependencies may be licensed differently).

Maven logo typedb-driver  2.28.4

One-liner (summary)

com.vaticle.typedb:typedb-driver:2.28.4

Description

TypeDB Java Driver

Size

332.6 KB

Downloads

4

Status  Completed
Checksum (MD5) 64a5638431089db8c3e40107eef0b54a
Checksum (SHA-1) 4f710dd5bf643820741679d26dbe14e6fa1df46d
Checksum (SHA-256) 2dc50582d56eaa8989bf2b0d37ad5286f386f6f51ecff96c6399b37d1ea8e210
Checksum (SHA-512) 62a6e4740fb34419195a991afd2539f4eb31ab428db8e7fee8bf10e1678ce51f02…
GPG Signature
GPG Fingerprint 43dc0336920ac3e94b31912517507562824cfdcc
Storage Region  Dublin, Ireland
Type  Binary (contains binaries and binary artifacts)
Uploaded At 1 week, 3 days ago
Uploaded By Uploaded by vaticle-bot
Slug Id typedb-driver-2284jar-4ipb
Unique Id GGwQe1wfjAO3
Version (Raw) 2.28.4
Version (Parsed)
  • Major: 2
  • Minor: 28
  • Patch: 4
  • Type: SemVer (Strict)
  extended metadata
Artifact Id typedb-driver
Group Id com.vaticle.typedb
Is Snapshot
Packaging jar
Url https://github.com/vaticle/typedb-driver-java
pkg typedb-driver-2.28.4.jar 1
133.1 KB
md5 sha1 sha256 sha512
javadoc typedb-driver-2.28.4-javadoc.jar 1
97.1 KB
md5 sha1 sha256 sha512
pom typedb-driver-2.28.4.pom 1
5.2 KB
md5 sha1 sha256 sha512
sources typedb-driver-2.28.4-sources.jar 1
97.1 KB
md5 sha1 sha256 sha512
Package Contents (typedb-driver-2.28.4.jar)
Loading...

This package has 124 files/directories.

  Maven logo
typedb-driver
 2.28.4
4 Uploaded by vaticle-bot
 Older Maven logo
typedb-driver
 2.28.1
0 Uploaded by vaticle-bot
 Older Maven logo
typedb-driver
 2.28.0
239 Uploaded by vaticle-bot
 Older Maven logo
typedb-driver
 2.27.0
338.5 KB 3 months ago
22 Uploaded by vaticle-bot
 Older Maven logo
typedb-driver
 2.26.6
1522 Uploaded by vaticle-bot
 Older Maven logo
typedb-driver
 2.26.5
24 krishnan-govindraj
 Older Maven logo
typedb-driver
 2.26.3
2 krishnan-govindraj
 Older Maven logo
typedb-driver
 2.26.1
6 krishnan-govindraj
 Older Maven logo
typedb-driver
 2.26.0
4 krishnan-govindraj
 Older Maven logo
typedb-driver
 2.25.8
3 krishnan-govindraj
 Older Maven logo
typedb-driver
 2.25.7
3 krishnan-govindraj
 Older Maven logo
typedb-driver
 2.25.6
3 krishnan-govindraj
 Older Maven logo
typedb-driver
 2.25.2
2 krishnan-govindraj
 Older Maven logo
typedb-driver
 2.25.1
3 krishnan-govindraj
 Older Maven logo
typedb-driver
 2.25.0
6 krishnan-govindraj
 Older Maven logo
typedb-driver
3 krishnan-govindraj
 Older Maven logo
typedb-driver
2 krishnan-govindraj
 Older Maven logo
typedb-driver
4 krishnan-govindraj
 Older Maven logo
typedb-driver
 2.24.8
3 krishnan-govindraj
 Older Maven logo
typedb-driver
 2.24.5
2 krishnan-govindraj

Dependencies

27

Checksum (md5)

d886fee5726fdbe71bda25123299861d

Compile
ch.qos.logback:logback-classic >=1.4.9
Compile
ch.qos.logback:logback-core >=1.4.9
Compile
com.eclipsesource.minimal-json:minimal-json >=0.9.5
Compile
com.google.code.findbugs:jsr305 >=3.0.2
Compile
com.vaticle.typedb:typedb-common >=2.28.1
Compile
com.vaticle.typedb:typedb-driver-jni-linux-arm64 >=2.28.4
Compile
com.vaticle.typedb:typedb-driver-jni-linux-x86_64 >=2.28.4
Compile
com.vaticle.typedb:typedb-driver-jni-macosx-arm64 >=2.28.4
Compile
com.vaticle.typedb:typedb-driver-jni-macosx-x86_64 >=2.28.4
Compile
com.vaticle.typedb:typedb-driver-jni-windows-x86_64 >=2.28.4
Compile
com.vaticle.typeql:typeql-builder >=2.28.1
Compile
com.vaticle.typeql:typeql-common >=2.28.1
Compile
com.vaticle.typeql:typeql-grammar >=2.28.1
Compile
com.vaticle.typeql:typeql-lang >=2.28.1
Compile
com.vaticle.typeql:typeql-parser >=2.28.1
Compile
com.vaticle.typeql:typeql-pattern >=2.28.1
Compile
com.vaticle.typeql:typeql-query >=2.28.1
Compile
io.netty:netty-tcnative-boringssl-static >=2.0.61.Final
Compile
io.netty:netty-tcnative-boringssl-static >=2.0.61.Final
Compile
io.netty:netty-tcnative-boringssl-static >=2.0.61.Final
Compile
io.netty:netty-tcnative-boringssl-static >=2.0.61.Final
Compile
io.netty:netty-tcnative-boringssl-static >=2.0.61.Final
Compile
io.netty:netty-tcnative-boringssl-static >=2.0.61.Final
Compile
io.netty:netty-tcnative-classes >=2.0.61.Final
Compile
org.antlr:antlr4-runtime >=4.8
Compile
org.slf4j:slf4j-api >=2.0.0
Compile
org.yaml:snakeyaml >=2.2

Security Scanning:
You can't see this because your subscription doesn't include this feature, sorry!

With Security Scanning, Cloudsmith will scan your artifacts for vulnerabilities when they're uploaded. These are then presented to you via the UI and the API, so that you can build rules into your CI/CD pipelines to decide how to handle low, medium, high and critical software vulnerabilities.

If you'd like to trial or ask about the Security Scanning feature, just ask us. We'll be happy to help!

Last scanned

3 weeks, 2 days ago

Scan result

Vulnerable

Vulnerability count

4

Max. severity

High
Target:
HIGH

CVE-8300-45594: library: vulnerability title



Package Name: package_name
Installed Version: 1.2.6
Fixed Version: 2.2.29

References: www.brown.biz smith-roberson.biz crawford.com
MEDIUM

CVE-7406-97447: library: vulnerability title



Package Name: package_name
Installed Version: 1.2.99
Fixed Version: 2.2.56

References: www.howard.com harmon.com www.hansen-murphy.com
MEDIUM

CVE-2874-29368: library: vulnerability title



Package Name: package_name
Installed Version: 1.1.53
Fixed Version: 2.10.70

References: www.collins.com reyes-ramirez.com moody-brooks.org
LOW

CVE-5031-67977: library: vulnerability title



Package Name: package_name
Installed Version: 1.8.95
Fixed Version: 2.8.74

References: www.rangel-campbell.com www.rodriguez.com www.warner.net
Loading...

You can embed a badge in another website that shows this or the latest version of this package.

To embed the badge for this specific package version, use the following:

[![This version of 'typedb-driver' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/typedb/public-release/maven/typedb-driver/2.28.4/a=noarch;xg=com.vaticle.typedb/?render=true)](https://cloudsmith.io/~typedb/repos/public-release/packages/detail/maven/typedb-driver/2.28.4/a=noarch;xg=com.vaticle.typedb/)
|This version of 'typedb-driver' @ Cloudsmith|
.. |This version of 'typedb-driver' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/typedb/public-release/maven/typedb-driver/2.28.4/a=noarch;xg=com.vaticle.typedb/?render=true
   :target: https://cloudsmith.io/~typedb/repos/public-release/packages/detail/maven/typedb-driver/2.28.4/a=noarch;xg=com.vaticle.typedb/
image::https://api-prd.cloudsmith.io/v1/badges/version/typedb/public-release/maven/typedb-driver/2.28.4/a=noarch;xg=com.vaticle.typedb/?render=true[link="https://cloudsmith.io/~typedb/repos/public-release/packages/detail/maven/typedb-driver/2.28.4/a=noarch;xg=com.vaticle.typedb/",title="This version of 'typedb-driver' @ Cloudsmith"]
<a href="https://cloudsmith.io/~typedb/repos/public-release/packages/detail/maven/typedb-driver/2.28.4/a=noarch;xg=com.vaticle.typedb/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/typedb/public-release/maven/typedb-driver/2.28.4/a=noarch;xg=com.vaticle.typedb/?render=true" alt="This version of 'typedb-driver' @ Cloudsmith" /></a>

rendered as: This version of 'typedb-driver' @ Cloudsmith

To embed the badge for the latest package version, use the following:

[![Latest version of 'typedb-driver' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/typedb/public-release/maven/typedb-driver/latest/a=noarch;xg=com.vaticle.typedb/?render=true&show_latest=true)](https://cloudsmith.io/~typedb/repos/public-release/packages/detail/maven/typedb-driver/latest/a=noarch;xg=com.vaticle.typedb/)
|Latest version of 'typedb-driver' @ Cloudsmith|
.. |Latest version of 'typedb-driver' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/typedb/public-release/maven/typedb-driver/latest/a=noarch;xg=com.vaticle.typedb/?render=true&show_latest=true
   :target: https://cloudsmith.io/~typedb/repos/public-release/packages/detail/maven/typedb-driver/latest/a=noarch;xg=com.vaticle.typedb/
image::https://api-prd.cloudsmith.io/v1/badges/version/typedb/public-release/maven/typedb-driver/latest/a=noarch;xg=com.vaticle.typedb/?render=true&show_latest=true[link="https://cloudsmith.io/~typedb/repos/public-release/packages/detail/maven/typedb-driver/latest/a=noarch;xg=com.vaticle.typedb/",title="Latest version of 'typedb-driver' @ Cloudsmith"]
<a href="https://cloudsmith.io/~typedb/repos/public-release/packages/detail/maven/typedb-driver/latest/a=noarch;xg=com.vaticle.typedb/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/typedb/public-release/maven/typedb-driver/latest/a=noarch;xg=com.vaticle.typedb/?render=true&show_latest=true" alt="Latest version of 'typedb-driver' @ Cloudsmith" /></a>

rendered as: Latest version of 'typedb-driver' @ Cloudsmith

These instructions assume you have setup the repository first (or read it).

To install/use typedb-driver @ version 2.28.4 ...

Then you can then depend on typedb-driver @ version 2.28.4, via:

Add the following to your project pom.xml file:

<dependency>
  <groupId>com.vaticle.typedb</groupId>
  <artifactId>typedb-driver</artifactId>
  <version>2.28.4</version>
</dependency>
dependencies {
  implementation 'com.vaticle.typedb:typedb-driver:2.28.4'
}

Note: These examples use the Groovy-based syntax for Gradle. For the Kotlin syntax, please refer to the official documentation for declaring dependencies.

Add the following to your project build.sbt file:

libraryDependencies += "com.vaticle.typedb" % "typedb-driver" % "2.28.4"

Add the following to your project project.clj file:

:dependencies [[com.vaticle.typedb/typedb-driver "2.28.4"]]

For other build systems, such as grape, please consult your build system documentation for more help.

Top