Package Search Help

You can use boolean logic (e.g. AND/OR/NOT) for complex search queries. For more help and examples, see the search documentation.

Search by package name:
my-package (implicit)
name:my-package (explicit)

Search by package filename:
my-package.ext (implicit)
filename:my-package.ext (explicit)

Search by package tag:
latest (implicit)
tag:latest (explicit)

Search by package version:
1.0.0 (implicit)
version:1.0.0 (explicit)
prerelease:true (prereleases)
prerelease:false (no prereleases)

Search by package architecture:
architecture:x86_64 

Search by package distribution:
distribution:el 

Search by package license:
license:MIT 

Search by package format:
format:deb 

Search by package status:
status:in_progress 

Search by package file checksum:
checksum:5afba 

Search by package security status:
severity:critical 

Search by package vulnerabilities:
vulnerabilities:>1 
vulnerabilities:<1000 

Search by # of package downloads:
downloads:>8 
downloads:<100 

Search by package type:
type:binary 
type:source 

Search by package size (bytes):
size:>50000 
size:<10000 

Search by dependency name/version:
dependency:log4j 
dependency:log4j=1.0.0 
dependency:log4j>1.0.0 

Search by uploaded date:
uploaded:>"1 day ago" 
uploaded:<"August 14, 2022 EST" 

Search by entitlement token (identifier):
entitlement:3lKPVJPosCsY 

Search by policy violation:
policy_violated:true
deny_policy_violated:true
license_policy_violated:true
vulnerability_policy_violated:true

Search by repository:
repository:repo-name

Search queries for all Debian-specific (and related) package types

Search by component:
deb_component:unstable

Search queries for all Maven-specific (and related) package types

Search by group ID:
maven_group_id:org.apache

Search queries for all Docker-specific (and related) package types

Search by image digest:
docker_image_digest:sha256:7c5..6d4
(full hashref only)

Search by layer digest:
docker_layer_digest:sha256:4c4..ae4
(full hashref only)

Field type modifiers (depending on the type, you can influence behaviour)

For all queries, you can use:
~foo for negation

For string queries, you can use:
^foo to anchor to start of term
foo$ to anchor to end of term
foo*bar for fuzzy matching

For number/date or version queries, you can use:
>foo for values greater than
>=foo for values greater / equal
<foo for values less than
<=foo for values less / equal

Need a secure and centralised artifact repository to deliver Alpine, Cargo, CocoaPods, Composer, Conan, Conda, CRAN, Dart, Debian, Docker, Go, Helm, Hex, LuaRocks, Maven, npm, NuGet, P2, Python, RedHat, Ruby, Swift, Terraform, Vagrant, Raw & More packages?

Cloudsmith is the new standard in Package / Artifact Management and Software Distribution.

With support for all major package formats, you can trust us to manage your software supply chain.

Start My Free Trial
 Public consensys consensys (Consensys) / teku
Teku: Teku is a Java implementation of the Ethereum 2.0 Beacon Chain.

Maven logo teku  21.2.0

One-liner (summary)

tech.pegasys.teku.internal:teku:21.2.0

Description

No description - See summary for more info.

Size

300.1 KB

Downloads

39

Status  Completed
Checksum (MD5) 6d4a913cc10c9483d548f8ac36fc8369
Checksum (SHA-1) ae32d5d94ccc9c8a82ed6d7392f1ad1ff70f060b
Checksum (SHA-256) f001814b17458c3c49178594c70c3bb25ae263f8573141271f6edb1660fd7e88
Checksum (SHA-512) 5e7b59383a3d450cdb3de20aff5bfa61b0282ff7049c7725090a489ac411422450…
GPG Signature
Storage Region  Dublin, Ireland
Type  Binary (contains binaries and binary artifacts)
Uploaded At 3 years, 3 months ago
Uploaded By Fetched by Cloudsmith
Slug Id teku-2120jar-PTa
Unique Id OFX29Odvyope
Version (Raw) 21.2.0
Version (Parsed)
  • Major: 21
  • Minor: 2
  • Patch: 0
  • Type: SemVer (Strict)
  extended metadata
Artifact Id teku
Group Id tech.pegasys.teku.internal
Packaging jar
Url https://github.com/ConsenSys/teku
pkg teku-21.2.0.jar 39
168.7 KB
md5 sha1 sha256 sha512
pom teku-21.2.0.pom 0
28.0 KB
md5 sha1 sha256 sha512
sources teku-21.2.0-sources.jar 0
103.4 KB
md5 sha1 sha256 sha512
Package Contents (teku-21.2.0.jar)
Loading...

This package has 114 files/directories.

Dependencies

60

Checksum (md5)

2f5b1d6531e7f81b820c6cd6f68694e6

Runtime
com.fasterxml.jackson.core:jackson-databind >=2.11.2
Runtime
com.fasterxml.jackson.dataformat:jackson-dataformat-yaml >=2.11.2
Runtime
com.google.code.gson:gson >=2.8.6
Runtime
com.squareup.okhttp3:okhttp >=4.8.1
Runtime
info.picocli:picocli >=4.4.0
Runtime
io.libp2p:jvm-libp2p-minimal >=0.7.0-RELEASE
Runtime
io.vertx:vertx-core >=3.9.1
Runtime
io.vertx:vertx-web >=3.9.1
Runtime
org.apache.commons:commons-lang3 >=3.10
Runtime
org.apache.logging.log4j:log4j-api >=2.13.3
Runtime
org.apache.logging.log4j:log4j-core >=2.13.3
Runtime
org.apache.logging.log4j:log4j-slf4j-impl >=2.13.3
Runtime
org.apache.tuweni:tuweni-crypto >=1.0.0
Runtime
org.apache.tuweni:tuweni-plumtree >=1.0.0
Runtime
org.apache.tuweni:tuweni-ssz >=1.0.0
Runtime
org.apache.tuweni:tuweni-toml >=1.0.0
Runtime
org.apache.tuweni:tuweni-units >=1.0.0
Runtime
org.hyperledger.besu.internal:metrics-core >=20.10.4
Runtime
tech.pegasys.signers.internal:bls-keystore >=1.0.13
Runtime
tech.pegasys.teku.internal:api >=21.2.0
Runtime
tech.pegasys.teku.internal:api >=21.2.0
Runtime
tech.pegasys.teku.internal:async >=21.2.0
Runtime
tech.pegasys.teku.internal:beaconchain >=21.2.0
Runtime
tech.pegasys.teku.internal:beaconrestapi >=21.2.0
Runtime
tech.pegasys.teku.internal:bls >=21.2.0
Runtime
tech.pegasys.teku.internal:chainstorage >=21.2.0
Runtime
tech.pegasys.teku.internal:client >=21.2.0
Runtime
tech.pegasys.teku.internal:coordinator >=21.2.0
Runtime
tech.pegasys.teku.internal:core >=21.2.0
Runtime
tech.pegasys.teku.internal:dataexchange >=21.2.0
Runtime
tech.pegasys.teku.internal:dataproviders >=21.2.0
Runtime
tech.pegasys.teku.internal:datastructures >=21.2.0
Runtime
tech.pegasys.teku.internal:eth2 >=21.2.0
Runtime
tech.pegasys.teku.internal:events >=21.2.0
Runtime
tech.pegasys.teku.internal:exceptions >=21.2.0
Runtime
tech.pegasys.teku.internal:logging >=21.2.0
Runtime
tech.pegasys.teku.internal:metrics >=21.2.0
Runtime
tech.pegasys.teku.internal:nat >=21.2.0
Runtime
tech.pegasys.teku.internal:networks >=21.2.0
Runtime
tech.pegasys.teku.internal:p2p >=21.2.0
Runtime
tech.pegasys.teku.internal:pow >=21.2.0
Runtime
tech.pegasys.teku.internal:powchain >=21.2.0
Runtime
tech.pegasys.teku.internal:protoarray >=21.2.0
Runtime
tech.pegasys.teku.internal:remote >=21.2.0
Runtime
tech.pegasys.teku.internal:serializer >=21.2.0
Runtime
tech.pegasys.teku.internal:serviceutils >=21.2.0
Runtime
tech.pegasys.teku.internal:spec >=21.2.0
Runtime
tech.pegasys.teku.internal:statetransition >=21.2.0
Runtime
tech.pegasys.teku.internal:storage >=21.2.0
Runtime
tech.pegasys.teku.internal:sync >=21.2.0
Runtime
tech.pegasys.teku.internal:timer >=21.2.0
Runtime
tech.pegasys.teku.internal:unsigned >=21.2.0
Runtime
tech.pegasys.teku.internal:util >=21.2.0
Runtime
tech.pegasys.teku.internal:version >=21.2.0
Runtime
tech.pegasys.teku.internal:weaksubjectivity >=21.2.0
Runtime
tech.pegasys.teku.internal:yaml >=21.2.0
Runtime
teku:data >=21.2.0
Compile
com.google.guava:guava >=29.0-jre
Compile
org.assertj:assertj-core >=None
Compile
tech.pegasys.teku.internal:teku >=21.2.0

Security Scanning:
You can't see this because your subscription doesn't include this feature, sorry!

With Security Scanning, Cloudsmith will scan your artifacts for vulnerabilities when they're uploaded. These are then presented to you via the UI and the API, so that you can build rules into your CI/CD pipelines to decide how to handle low, medium, high and critical software vulnerabilities.

If you'd like to trial or ask about the Security Scanning feature, just ask us. We'll be happy to help!

Last scanned

3 days, 1 hour ago

Scan result

Vulnerable

Vulnerability count

1

Max. severity

Medium
Target:
MEDIUM

CVE-7226-22153: library: vulnerability title



Package Name: package_name
Installed Version: 1.4.88
Fixed Version: 2.5.53

References: perkins-white.com www.peck-charles.com www.wood-clark.biz
Loading...

You can embed a badge in another website that shows this or the latest version of this package.

To embed the badge for this specific package version, use the following:

[![This version of 'teku' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/teku/21.2.0/a=noarch;xg=tech.pegasys.teku.internal/?render=true)](https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/teku/21.2.0/a=noarch;xg=tech.pegasys.teku.internal/)
|This version of 'teku' @ Cloudsmith|
.. |This version of 'teku' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/teku/21.2.0/a=noarch;xg=tech.pegasys.teku.internal/?render=true
   :target: https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/teku/21.2.0/a=noarch;xg=tech.pegasys.teku.internal/
image::https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/teku/21.2.0/a=noarch;xg=tech.pegasys.teku.internal/?render=true[link="https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/teku/21.2.0/a=noarch;xg=tech.pegasys.teku.internal/",title="This version of 'teku' @ Cloudsmith"]
<a href="https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/teku/21.2.0/a=noarch;xg=tech.pegasys.teku.internal/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/teku/21.2.0/a=noarch;xg=tech.pegasys.teku.internal/?render=true" alt="This version of 'teku' @ Cloudsmith" /></a>

rendered as: This version of 'teku' @ Cloudsmith

To embed the badge for the latest package version, use the following:

[![Latest version of 'teku' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/teku/latest/a=noarch;xg=tech.pegasys.teku.internal/?render=true&show_latest=true)](https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/teku/latest/a=noarch;xg=tech.pegasys.teku.internal/)
|Latest version of 'teku' @ Cloudsmith|
.. |Latest version of 'teku' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/teku/latest/a=noarch;xg=tech.pegasys.teku.internal/?render=true&show_latest=true
   :target: https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/teku/latest/a=noarch;xg=tech.pegasys.teku.internal/
image::https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/teku/latest/a=noarch;xg=tech.pegasys.teku.internal/?render=true&show_latest=true[link="https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/teku/latest/a=noarch;xg=tech.pegasys.teku.internal/",title="Latest version of 'teku' @ Cloudsmith"]
<a href="https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/teku/latest/a=noarch;xg=tech.pegasys.teku.internal/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/teku/latest/a=noarch;xg=tech.pegasys.teku.internal/?render=true&show_latest=true" alt="Latest version of 'teku' @ Cloudsmith" /></a>

rendered as: Latest version of 'teku' @ Cloudsmith

These instructions assume you have setup the repository first (or read it).

To install/use teku @ version 21.2.0 ...

Then you can then depend on teku @ version 21.2.0, via:

Add the following to your project pom.xml file:

<dependency>
  <groupId>tech.pegasys.teku.internal</groupId>
  <artifactId>teku</artifactId>
  <version>21.2.0</version>
</dependency>
dependencies {
  implementation 'tech.pegasys.teku.internal:teku:21.2.0'
}

Note: These examples use the Groovy-based syntax for Gradle. For the Kotlin syntax, please refer to the official documentation for declaring dependencies.

Add the following to your project build.sbt file:

libraryDependencies += "tech.pegasys.teku.internal" % "teku" % "21.2.0"

Add the following to your project project.clj file:

:dependencies [[tech.pegasys.teku.internal/teku "21.2.0"]]

For other build systems, such as grape, please consult your build system documentation for more help.

Previous Version
Top