Package Search Help

You can use boolean logic (e.g. AND/OR/NOT) for complex search queries. For more help and examples, see the search documentation.

Search by package name:
my-package (implicit)
name:my-package (explicit)

Search by package filename:
my-package.ext (implicit)
filename:my-package.ext (explicit)

Search by package tag:
latest (implicit)
tag:latest (explicit)

Search by package version:
1.0.0 (implicit)
version:1.0.0 (explicit)
prerelease:true (prereleases)
prerelease:false (no prereleases)

Search by package architecture:
architecture:x86_64 

Search by package distribution:
distribution:el 

Search by package license:
license:MIT 

Search by package format:
format:deb 

Search by package status:
status:in_progress 

Search by package file checksum:
checksum:5afba 

Search by package security status:
severity:critical 

Search by package vulnerabilities:
vulnerabilities:>1 
vulnerabilities:<1000 

Search by package downloads:
downloads:>8 
downloads:<100 

Search by package type:
type:binary 
type:source 

Search by package size (bytes):
size:>50000 
size:<10000 

Search by dependency name:
dependency:log4j 

Search by uploaded date:
uploaded:>"1 day ago" 
uploaded:<"August 14, 2018 EST" 

Search by entitlement token (identifier):
entitlement:3lKPVJPosCsY 

Search queries for all Maven-specific (and related) package types

Search by group ID:
maven_group_id:org.apache 

Field type modifiers (depending on the type, you can influence behaviour)

For all queries, you can use:
~foo for negation

For string queries, you can use:
^foo to anchor to start of term
foo$ to anchor to end of term
foo*bar for fuzzy matching

For number/date queries, you can use:
>foo for values greater than
>=foo for values greater / equal
<foo for values less than
<=foo for values less / equal

Need a secure and centralised artifact repository to deliver Alpine, Cargo, CocoaPods, Composer, Conan, Conda, CRAN, Dart, Debian, Docker, Go, Helm, LuaRocks, Maven, npm, NuGet, P2, Python, RedHat, Ruby, Terraform, Vagrant, Raw & More packages?

Cloudsmith is the new standard in Package / Artifact Management and Software Distribution.

With support for all major package formats, you can trust us to manage your software supply chain.

Start My Free Trial
 Public consensys consensys (ConsenSys) / teku
Teku: Teku is a Java implementation of the Ethereum 2.0 Beacon Chain.

Maven logo ssz  22.5.0

One-liner (summary)

tech.pegasys.teku.internal:ssz:22.5.0

Description

No description - See summary for more info.

Size

576.4 KB

Downloads

132

Status  Completed
Checksum (MD5) 4b8949aff30b27c3a284b860d9a5cff3
Checksum (SHA-1) 0994fdb3d16d618d51ee972c9cb1e2556c4b3ed1
Checksum (SHA-256) fbcc9ed66530cdfacb58d781d6c9601c49e63f7a45d026d83e7c64dc931424e3
Checksum (SHA-512) 84677b2949f208755a5cca8331625271d911c3e6b0a5eb79ea109ab525fd30c308…
GPG Signature
Storage Region Default Region
Type  Binary (contains binaries and binary artifacts)
Uploaded At 6 months, 3 weeks ago
Uploaded By cs-ops
Slug Id NlcfqFR6SuNu-WDw
Unique Id c3dDO8LsDihf
Version (Raw) 22.5.0
Version (Parsed)
  • Major: 22
  • Minor: 5
  • Patch: 0
  • Type: SemVer (Strict)
  extended metadata
Artifact Id ssz
Group Id tech.pegasys.teku.internal
Is Snapshot
Packaging jar
Url https://github.com/ConsenSys/teku
  dependencies
Checksum (MD5) b8ff55b2231661d4042381e6d6c830d8
Runtime com.fasterxml.jackson.core:jackson-databind >= 2.13.2.2 | com.google.guava:guava >= 31.1-jre | it.unimi.dsi:fastutil >= 8.5.8 | org.apache.commons:commons-lang3 >= 3.12.0 | org.apache.logging.log4j:log4j-api >= 2.17.2 | org.apache.logging.log4j:log4j-core >= 2.17.2 | org.apache.logging.log4j:log4j-slf4j-impl >= 2.17.2 | org.apache.tuweni:tuweni-bytes >= 2.2.0 | org.apache.tuweni:tuweni-ssz >= 2.2.0 | org.apache.tuweni:tuweni-units >= 2.2.0 | tech.pegasys.teku.internal:bytes >= 22.5.0 | tech.pegasys.teku.internal:crypto >= 22.5.0 | tech.pegasys.teku.internal:unsigned >= 22.5.0
Compile org.apiguardian:apiguardian-api >= None | org.assertj:assertj-core >= None | tech.pegasys.teku.internal:json >= 22.5.0 | tech.pegasys.teku.internal:ssz >= 22.5.0
pkg ssz-22.5.0.jar 46
322.2 KB
md5 sha1 sha256 sha512
module ssz-22.5.0.module 41
8.1 KB
md5 sha1 sha256 sha512
pom ssz-22.5.0.pom 41
20.2 KB
md5 sha1 sha256 sha512
sources ssz-22.5.0-sources.jar 4
214.7 KB
md5 sha1 sha256 sha512
test-fixtures ssz-22.5.0-test-fixtures.jar 0
11.0 KB
md5 sha1 sha256 sha512
Package Contents (ssz-22.5.0.jar)
Loading...

This package has 248 files/directories.

 Newer Maven logo
ssz
0 Uploaded by ops-quorum-sa
 Newer Maven logo
ssz
 22.9.0
166 Uploaded by ops-quorum-sa
 Newer Maven logo
ssz
 22.8.2
35 Uploaded by ops-quorum-sa
 Newer Maven logo
ssz
 22.8.1
125 Uploaded by ops-quorum-sa
 Newer Maven logo
ssz
 22.8.0
129 cs-ops
 Newer Maven logo
ssz
 22.7.0
63 cs-ops
 Newer Maven logo
ssz
 22.6.1
587.9 KB 5 months ago
4 cs-ops
 Newer Maven logo
ssz
 22.6.0
117 cs-ops
 Newer Maven logo
ssz
 22.5.2
580.0 KB 6 months ago
3 cs-ops
 Newer Maven logo
ssz
 22.5.1
58 cs-ops
  Maven logo
ssz
 22.5.0
132 cs-ops
 Older Maven logo
ssz
 22.4.0
24 cs-ops
 Older Maven logo
ssz
 22.3.2
12 cs-ops
 Older Maven logo
ssz
 22.3.1
252 cs-ops
 Older Maven logo
ssz
 22.3.0
38 cs-ops
 Older Maven logo
ssz
 22.1.1
560.7 KB 10 months ago
88 cs-ops
 Older Maven logo
ssz
 22.1.0
16 cs-ops
 Older Maven logo
ssz
9 cs-ops
 Older Maven logo
ssz
13 cs-ops
 Older Maven logo
ssz
16 cs-ops

Last scanned

Never

Scan result

N/A

Vulnerability count

0

Max. severity

UNKNOWN
Loading...

You can embed a badge in another website that shows this or the latest version of this package.

To embed the badge for this specific package version, use the following:

[![This version of 'ssz' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/ssz/22.5.0/a=noarch;xg=tech.pegasys.teku.internal/?render=true)](https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/ssz/22.5.0/a=noarch;xg=tech.pegasys.teku.internal/)
|This version of 'ssz' @ Cloudsmith|
.. |This version of 'ssz' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/ssz/22.5.0/a=noarch;xg=tech.pegasys.teku.internal/?render=true
   :target: https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/ssz/22.5.0/a=noarch;xg=tech.pegasys.teku.internal/
image::https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/ssz/22.5.0/a=noarch;xg=tech.pegasys.teku.internal/?render=true[link="https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/ssz/22.5.0/a=noarch;xg=tech.pegasys.teku.internal/",title="This version of 'ssz' @ Cloudsmith"]
<a href="https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/ssz/22.5.0/a=noarch;xg=tech.pegasys.teku.internal/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/ssz/22.5.0/a=noarch;xg=tech.pegasys.teku.internal/?render=true" alt="This version of 'ssz' @ Cloudsmith" /></a>

rendered as: This version of 'ssz' @ Cloudsmith

To embed the badge for the latest package version, use the following:

[![Latest version of 'ssz' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/ssz/latest/a=noarch;xg=tech.pegasys.teku.internal/?render=true&show_latest=true)](https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/ssz/latest/a=noarch;xg=tech.pegasys.teku.internal/)
|Latest version of 'ssz' @ Cloudsmith|
.. |Latest version of 'ssz' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/ssz/latest/a=noarch;xg=tech.pegasys.teku.internal/?render=true&show_latest=true
   :target: https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/ssz/latest/a=noarch;xg=tech.pegasys.teku.internal/
image::https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/ssz/latest/a=noarch;xg=tech.pegasys.teku.internal/?render=true&show_latest=true[link="https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/ssz/latest/a=noarch;xg=tech.pegasys.teku.internal/",title="Latest version of 'ssz' @ Cloudsmith"]
<a href="https://cloudsmith.io/~consensys/repos/teku/packages/detail/maven/ssz/latest/a=noarch;xg=tech.pegasys.teku.internal/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/consensys/teku/maven/ssz/latest/a=noarch;xg=tech.pegasys.teku.internal/?render=true&show_latest=true" alt="Latest version of 'ssz' @ Cloudsmith" /></a>

rendered as: Latest version of 'ssz' @ Cloudsmith

These instructions assume you have setup the repository first (or read it).

To install/use ssz @ version 22.5.0 ...

Then you can then depend on ssz @ version 22.5.0, via:

Add the following to your project pom.xml file:

<dependency>
  <groupId>tech.pegasys.teku.internal</groupId>
  <artifactId>ssz</artifactId>
  <version>22.5.0</version>
</dependency>
dependencies {
  implementation 'tech.pegasys.teku.internal:ssz:22.5.0'
}

Note: These examples use the Groovy-based syntax for Gradle. For the Kotlin syntax, please refer to the official documentation for declaring dependencies.

Add the following to your project build.sbt file:

libraryDependencies += "tech.pegasys.teku.internal" % "ssz" % "22.5.0"

Add the following to your project project.clj file:

:dependencies [[tech.pegasys.teku.internal/ssz "22.5.0"]]

For other build systems, such as grape, please consult your build system documentation for more help.

Top