Need your own package repository for Alpine, Cargo, CocoaPods, Composer, Conan, CRAN, Dart, Debian, Docker, Go, Helm, LuaRocks, Maven, npm, NuGet, Python, RedHat, Ruby, Terraform, Vagrant, Raw & More?

Cloudsmith provides better DevOps with simple and secure delivery of your software, from dev to production.

Start My Free 7-Day Trial
 Open-Source wand wand / dpdk-wand Project
A certifiably-awesome open-source package repository curated by wand, hosted by Cloudsmith.
Note: Packages in this repository are licensed as BSD 3-clause "New" or "Revised" License (dependencies may be licensed differently).

Debian logo libibverbs-dev  19.0-1

One-liner (summary)

Development files for the libibverbs library

Description

libibverbs is a library that allows userspace processes to use RDMA "verbs" as described in the InfiniBand Architecture Specification and the RDMA Protocol Verbs Specification. iWARP ethernet NICs support RDMA over hardware-offloaded TCP/IP, while InfiniBand is a high-throughput, low-latency networking technology. InfiniBand host channel adapters (HCAs) and iWARP NICs commonly support direct hardware access from userspace (kernel bypass), and libibverbs supports this when available.

This package is needed to compile programs against libibverbs1. It contains the header files and static libraries (optionally) needed for compiling.

License

Unknown

Size

118.5 KB

Downloads

3

Status  Completed
Checksum (MD5) c2dc8bc46fca95ef7f45a90c1c458711
Checksum (SHA-1) f705d8d897899ef44b70f9aeecb2b62565b8622b
Checksum (SHA-256) 3f27baf5b44eea53d78c21911490bff33996355fe87bf7fe03a9f79d9ac59bc0
Checksum (SHA-512) 1700b3ee23660499b7e906017ec2c5575006ac2f27c32c9de99f5a59a27fb7fce2…
GPG Signature
Distribution ubuntu/xenial - Ubuntu - 16.04 LTS Xenial Xerus
Storage Region Default Region
Type  Binary (contains binaries and binary artifacts)
Uploaded At 1 year ago
Uploaded By salcock-9Dw
Slug Id libibverbs-dev_190-1_amd64deb-3
Unique Id 2VKOkqTO7rte
Version (Raw) 19.0-1
Version (Parsed)
  • Major: 19
  • Minor: 0
  • Pre (Str): (empty)
  • Pre (Num): 1
  • Type: SemVer (Compat)
  extended metadata
Homepage https://github.com/linux-rdma/rdma-core
Installed Size 327.0 KB
Maintainer Linux RDMA Mailing List <linux-rdma@vger.kernel.org>
Multi Arch same
Priority optional
Section libdevel
Source rdma-core
  dependencies
Checksum (MD5) 1bde253b89a20d10da312ca810672bc3
Depends ibverbs-providers = 19.0-1 | libibverbs1 = 19.0-1
pkg libibverbs-dev_19.0-1_amd64.deb 3
118.5 KB
md5 sha1 sha256 sha512
Package Contents (libibverbs-dev_19.0-1_amd64.deb)
Loading...

This package has 127 files/directories.

Loading...

You can embed a badge in another website that shows this or the latest version of this package.

To embed the badge for this specific package version, use the following:

[![This version of 'libibverbs-dev' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/wand/dpdk-wand/deb/libibverbs-dev/19.0-1/a=amd64;d=ubuntu%252Fxenial;t=binary/?render=true)](https://cloudsmith.io/~wand/repos/dpdk-wand/packages/detail/deb/libibverbs-dev/19.0-1/a=amd64;d=ubuntu%252Fxenial;t=binary/)
|This version of 'libibverbs-dev' @ Cloudsmith|
.. |This version of 'libibverbs-dev' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/wand/dpdk-wand/deb/libibverbs-dev/19.0-1/a=amd64;d=ubuntu%252Fxenial;t=binary/?render=true
   :target: https://cloudsmith.io/~wand/repos/dpdk-wand/packages/detail/deb/libibverbs-dev/19.0-1/a=amd64;d=ubuntu%252Fxenial;t=binary/
image::https://api-prd.cloudsmith.io/v1/badges/version/wand/dpdk-wand/deb/libibverbs-dev/19.0-1/a=amd64;d=ubuntu%252Fxenial;t=binary/?render=true[link="https://cloudsmith.io/~wand/repos/dpdk-wand/packages/detail/deb/libibverbs-dev/19.0-1/a=amd64;d=ubuntu%252Fxenial;t=binary/",title="This version of 'libibverbs-dev' @ Cloudsmith"]
<a href="https://cloudsmith.io/~wand/repos/dpdk-wand/packages/detail/deb/libibverbs-dev/19.0-1/a=amd64;d=ubuntu%252Fxenial;t=binary/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/wand/dpdk-wand/deb/libibverbs-dev/19.0-1/a=amd64;d=ubuntu%252Fxenial;t=binary/?render=true" alt="This version of 'libibverbs-dev' @ Cloudsmith" /></a>

rendered as: This version of 'libibverbs-dev' @ Cloudsmith

To embed the badge for the latest package version, use the following:

[![Latest version of 'libibverbs-dev' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/wand/dpdk-wand/deb/libibverbs-dev/latest/a=amd64;d=ubuntu%252Fxenial;t=binary/?render=true&show_latest=true)](https://cloudsmith.io/~wand/repos/dpdk-wand/packages/detail/deb/libibverbs-dev/latest/a=amd64;d=ubuntu%252Fxenial;t=binary/)
|Latest version of 'libibverbs-dev' @ Cloudsmith|
.. |Latest version of 'libibverbs-dev' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/wand/dpdk-wand/deb/libibverbs-dev/latest/a=amd64;d=ubuntu%252Fxenial;t=binary/?render=true&show_latest=true
   :target: https://cloudsmith.io/~wand/repos/dpdk-wand/packages/detail/deb/libibverbs-dev/latest/a=amd64;d=ubuntu%252Fxenial;t=binary/
image::https://api-prd.cloudsmith.io/v1/badges/version/wand/dpdk-wand/deb/libibverbs-dev/latest/a=amd64;d=ubuntu%252Fxenial;t=binary/?render=true&show_latest=true[link="https://cloudsmith.io/~wand/repos/dpdk-wand/packages/detail/deb/libibverbs-dev/latest/a=amd64;d=ubuntu%252Fxenial;t=binary/",title="Latest version of 'libibverbs-dev' @ Cloudsmith"]
<a href="https://cloudsmith.io/~wand/repos/dpdk-wand/packages/detail/deb/libibverbs-dev/latest/a=amd64;d=ubuntu%252Fxenial;t=binary/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/wand/dpdk-wand/deb/libibverbs-dev/latest/a=amd64;d=ubuntu%252Fxenial;t=binary/?render=true&show_latest=true" alt="Latest version of 'libibverbs-dev' @ Cloudsmith" /></a>

rendered as: Latest version of 'libibverbs-dev' @ Cloudsmith

These instructions assume you have setup the repository first (or read it).

To install/use libibverbs-dev @ version 19.0-1 ...

To install packages, you can quickly setup the repository automatically (recommended):

curl -1sLf \
  'https://dl.cloudsmith.io/public/wand/dpdk-wand/setup.deb.sh' \
  | sudo -E bash

If you need to force a specific distribution, release/version, or even architecture, you can also do that (e.g. if your system is compatible but not identical):

curl -1sLf \
  'https://dl.cloudsmith.io/public/wand/dpdk-wand/setup.deb.sh' \
  | sudo -E distro=ubuntu codename=xenial arch=some-arch bash

or ... you can manually configure it yourself before installing packages:

apt-get install -y debian-keyring  # debian only
apt-get install -y debian-archive-keyring  # debian only
apt-get install -y apt-transport-https
curl -1sLf 'https://dl.cloudsmith.io/public/wand/dpdk-wand/gpg.5B3F3A34FF3A2715.key' | apt-key add -
curl -1sLf 'https://dl.cloudsmith.io/public/wand/dpdk-wand/config.deb.txt?distro=ubuntu&codename=xenial' > /etc/apt/sources.list.d/wand-dpdk-wand.list
apt-get update
sudo apt-get install libibverbs-dev=19.0-1
Warning: Note that this package is for Ubuntu 16.04 LTS Xenial Xerus / amd64 and may only work for that configuration.
Top