Need your own package repository for
Alpine, Cargo, Composer, CRAN, Debian, Docker, Go, Helm, LuaRocks, Maven, npm, NuGet, Python, RedHat, Ruby, Vagrant, Raw & More?
Cloudsmith provides better DevOps with simple and secure delivery of your software, from dev to production.

Start My Free 7-Day Trial
Set Me Up
 Open-Source isc isc (ISC - Internet Systems Consortium) / bind-dev Project
BIND 9 (Development Version): A certifiably-awesome open-source package repository curated by ISC - Internet Systems Consortium, hosted by Cloudsmith.
Note: Packages in this repository are licensed as Mozilla Public License 2.0 (dependencies may be licensed differently).

libidn2-dev  2.2.0-2+0~201...

uploaded 6 days, 3 hours ago

Format

Debian logo Debian (deb)

Status

 Sync Completed

License

Unknown

Size

132.8 KB

Downloads

0

One-liner (summary)

Internationalized domain names (IDNA2008/TR46) development files

Description

Libidn2 implements the revised algorithm for internationalized domain names called IDNA2008/TR46.

This package contains header files and libraries for static linking.
Unique Id VqNSR3BtrY5E
Sequential Id 609
Package libidn2-dev
Version 2.2.0-2+0~20190911.8+debian9~1.gbp25d6df
Type  Binary (contains binaries and binary artifacts)
Distribution debian/stretch - Debian - 9 (Stretch)
MD5 d00b59f2fb3b52aeb980053da7e6b087
SHA-1 24f688fd6a38164f597e6645437898f7cdcce979
SHA-256 994174f041250bbc6cee603f69ebf6c53a1feeda4be44998002758cf09624e19
SHA-512 ae215b9e3b2653d6203df7c4e6131062b1d500e278e9bc6433b4f791250e2179...
Homepage https://www.gnu.org/software/libidn/#libidn2
Installed Size 457.0 KB
Priority optional
Section libdevel
Source libidn2
Depends libidn2-0 = 2.2.0-2+0~20190911.8+debian9~1.gbp25d6df
Replaces libidn2-0-dev << 2.0.3-1~
Breaks libidn2-0-dev << 2.0.3-1~
Provides libidn2-0-dev
pkg libidn2-dev_2.2.0-2+0~2019091... 0
132.8 KB
md5 sha1 sha256 sha512
Package Contents (libidn2-dev_2.2.0-2+0~20190911.8+debian9~1.gbp25d6df_i386.deb)
Loading...

This package has 43 files/directories.

 Same Debian logo
libidn2-dev 2.2.0-2+0~20190911.8+debian9~...
0 ondrej-sury
 Same Debian logo
libidn2-dev 2.2.0-2+0~20190911.8+debian9~...
0 ondrej-sury
 Same Debian logo
libidn2-dev 2.2.0-2+0~20190911.8+debian9~...
0 ondrej-sury
 Same Debian logo
libidn2-dev 2.2.0-2+0~20190911.8+debian9~...
0 ondrej-sury
 Same Debian logo
libidn2-dev 2.2.0-2+0~20190911.7+debian9~...
0 ondrej-sury
 Older Debian logo
libidn2-dev 2.2.0-1+0~20190910.6+debian9~...
0 ondrej-sury
 Older Debian logo
libidn2-dev 2.2.0-1+0~20190910.6+debian9~...
0 ondrej-sury
 Older Debian logo
libidn2-dev 2.2.0-1+0~20190910.6+debian9~...
0 ondrej-sury
 Older Debian logo
libidn2-dev 2.2.0-1+0~20190910.6+debian9~...
0 ondrej-sury
 Older Debian logo
libidn2-dev 2.0.5-2~20181005094131.5+stretch
3 ondrej-sury
 Older Debian logo
libidn2-dev 2.0.5-2~20181005094131.5+stretch
1 ondrej-sury
 Older Debian logo
libidn2-dev 2.0.5-2~20181005094131.5+stretch
3 ondrej-sury
 Older Debian logo
libidn2-dev 2.0.5-2~20181005094131.5+stretch
3 ondrej-sury
 Older Debian logo
libidn2-dev 2.0.5-2~20181004135106.4+buster
2 ondrej-sury
 Older Debian logo
libidn2-dev 2.0.5-2~20181004135106.4+buster
1 ondrej-sury
 Older Debian logo
libidn2-dev 2.0.5-2~20181004135106.4+buster
3 ondrej-sury
Loading...

You can embed a badge in another website that shows this or the latest version of this package.

To embed the badge for this specific package version, use the following:

[![This Version @ Cloudsmith](https://api-prd.cloudsmith.io/badges/version/isc/bind-dev/deb/libidn2-dev/2.2.0-2+0~20190911.8+debian9~1.gbp25d6df/d=debian%252Fstretch/?render=true&badge_token=gAAAAABdgMCzZermOX-I0WGBxdh40sHDMYwqqC7OoQc3GZJN7pwRAhlgZ-FgxfedJsQ8QA6F_E3y02corDH92hsx4RQ6yOFf3zSH50c2rRqtw2leUmEJUSU%3D)](https://cloudsmith.io/~isc/repos/bind-dev/packages/detail/deb/libidn2-dev/2.2.0-2+0~20190911.8+debian9~1.gbp25d6df/d=debian%252Fstretch/)
|This Version @ Cloudsmith|
.. |This Version @ Cloudsmith| image:: https://api-prd.cloudsmith.io/badges/version/isc/bind-dev/deb/libidn2-dev/2.2.0-2+0~20190911.8+debian9~1.gbp25d6df/d=debian%252Fstretch/?render=true&badge_token=gAAAAABdgMCzZermOX-I0WGBxdh40sHDMYwqqC7OoQc3GZJN7pwRAhlgZ-FgxfedJsQ8QA6F_E3y02corDH92hsx4RQ6yOFf3zSH50c2rRqtw2leUmEJUSU%3D
   :target: https://cloudsmith.io/~isc/repos/bind-dev/packages/detail/deb/libidn2-dev/2.2.0-2+0~20190911.8+debian9~1.gbp25d6df/d=debian%252Fstretch/
image::https://api-prd.cloudsmith.io/badges/version/isc/bind-dev/deb/libidn2-dev/2.2.0-2+0~20190911.8+debian9~1.gbp25d6df/d=debian%252Fstretch/?render=true&badge_token=gAAAAABdgMCzZermOX-I0WGBxdh40sHDMYwqqC7OoQc3GZJN7pwRAhlgZ-FgxfedJsQ8QA6F_E3y02corDH92hsx4RQ6yOFf3zSH50c2rRqtw2leUmEJUSU%3D[link="https://cloudsmith.io/~isc/repos/bind-dev/packages/detail/deb/libidn2-dev/2.2.0-2+0~20190911.8+debian9~1.gbp25d6df/d=debian%252Fstretch/",title="This Version @ Cloudsmith"]
<a href="https://cloudsmith.io/~isc/repos/bind-dev/packages/detail/deb/libidn2-dev/2.2.0-2+0~20190911.8+debian9~1.gbp25d6df/d=debian%252Fstretch/"><img src="https://api-prd.cloudsmith.io/badges/version/isc/bind-dev/deb/libidn2-dev/2.2.0-2+0~20190911.8+debian9~1.gbp25d6df/d=debian%252Fstretch/?render=true&badge_token=gAAAAABdgMCzZermOX-I0WGBxdh40sHDMYwqqC7OoQc3GZJN7pwRAhlgZ-FgxfedJsQ8QA6F_E3y02corDH92hsx4RQ6yOFf3zSH50c2rRqtw2leUmEJUSU%3D" alt="This Version @ Cloudsmith" /></a>

rendered as: This Version @ Cloudsmith

To embed the badge for the latest package version, use the following:

[![Latest Version @ Cloudsmith](https://api-prd.cloudsmith.io/badges/version/isc/bind-dev/deb/libidn2-dev/latest/d=debian%252Fstretch/?render=true&badge_token=gAAAAABdgMCzqpT0uqtpAbdZTnDf2ahu_rAy7BIkWXDQ2WM_f0EjtQEjCkyIV_V-87umUnghwtTG7615qfw5-yjGjEMIJbxqX2i2KE33pU6O-4GwWTFLa84%3D)](https://cloudsmith.io/~isc/repos/bind-dev/packages/detail/deb/libidn2-dev/latest/d=debian%252Fstretch/)
|Latest Version @ Cloudsmith|
.. |Latest Version @ Cloudsmith| image:: https://api-prd.cloudsmith.io/badges/version/isc/bind-dev/deb/libidn2-dev/latest/d=debian%252Fstretch/?render=true&badge_token=gAAAAABdgMCzqpT0uqtpAbdZTnDf2ahu_rAy7BIkWXDQ2WM_f0EjtQEjCkyIV_V-87umUnghwtTG7615qfw5-yjGjEMIJbxqX2i2KE33pU6O-4GwWTFLa84%3D
   :target: https://cloudsmith.io/~isc/repos/bind-dev/packages/detail/deb/libidn2-dev/latest/d=debian%252Fstretch/
image::https://api-prd.cloudsmith.io/badges/version/isc/bind-dev/deb/libidn2-dev/latest/d=debian%252Fstretch/?render=true&badge_token=gAAAAABdgMCzqpT0uqtpAbdZTnDf2ahu_rAy7BIkWXDQ2WM_f0EjtQEjCkyIV_V-87umUnghwtTG7615qfw5-yjGjEMIJbxqX2i2KE33pU6O-4GwWTFLa84%3D[link="https://cloudsmith.io/~isc/repos/bind-dev/packages/detail/deb/libidn2-dev/latest/d=debian%252Fstretch/",title="Latest Version @ Cloudsmith"]
<a href="https://cloudsmith.io/~isc/repos/bind-dev/packages/detail/deb/libidn2-dev/latest/d=debian%252Fstretch/"><img src="https://api-prd.cloudsmith.io/badges/version/isc/bind-dev/deb/libidn2-dev/latest/d=debian%252Fstretch/?render=true&badge_token=gAAAAABdgMCzqpT0uqtpAbdZTnDf2ahu_rAy7BIkWXDQ2WM_f0EjtQEjCkyIV_V-87umUnghwtTG7615qfw5-yjGjEMIJbxqX2i2KE33pU6O-4GwWTFLa84%3D" alt="Latest Version @ Cloudsmith" /></a>

rendered as: Latest Version @ Cloudsmith

These instructions assume you have setup the repository first (or read it).

To install/use libidn2-dev @ version 2.2.0-2+0~20190911.8+debian9~1.gbp25d6df ...

To install packages, you can quickly setup the repository automatically (recommended):

curl -1sLf \
  'https://dl.cloudsmith.io/public/isc/bind-dev/cfg/setup/bash.deb.sh' \
  | sudo bash

If you need to force a specific distribution/release, you can also do that (e.g. if your system is compatible but not identical):

curl -1sLf \
  'https://dl.cloudsmith.io/public/isc/bind-dev/cfg/setup/bash.deb.sh' \
  | sudo distro=debian codename=stretch bash

or ... you can manually configure it yourself before installing packages:

apt-get install -y debian-keyring  # debian only
apt-get install -y debian-archive-keyring  # debian only
apt-get install -y apt-transport-https
curl -1sLf 'https://dl.cloudsmith.io/public/isc/bind-dev/cfg/gpg/gpg.2F3A808F03749146.key' | apt-key add -
curl -1sLf 'https://dl.cloudsmith.io/public/isc/bind-dev/cfg/setup/config.deb.txt?distro=debian&codename=stretch' > /etc/apt/sources.list.d/isc-bind-dev.list
apt-get update
sudo apt-get install libidn2-dev=2.2.0-2+0~20190911.8+debian9~1.gbp25d6df
Warning: Note that this package is for Debian 9 (Stretch) / i386 and may only work for that configuration.
Top