Package Search Help

You can use boolean logic (e.g. AND/OR/NOT) for complex search queries. For more help and examples, see the search documentation.

Search by package name:
my-package (implicit)
name:my-package (explicit)

Search by package filename:
my-package.ext (implicit)
filename:my-package.ext (explicit)

Search by package tag:
latest (implicit)
tag:latest (explicit)

Search by package version:
1.0.0 (implicit)
version:1.0.0 (explicit)
prerelease:true (prereleases)
prerelease:false (no prereleases)

Search by package architecture:
architecture:x86_64 

Search by package distribution:
distribution:el 

Search by package license:
license:MIT 

Search by package format:
format:deb 

Search by package status:
status:in_progress 

Search by package file checksum:
checksum:5afba 

Search by package security status:
severity:critical 

Search by package vulnerabilities:
vulnerabilities:>1 
vulnerabilities:<1000 

Search by # of package downloads:
downloads:>8 
downloads:<100 

Search by package type:
type:binary 
type:source 

Search by package size (bytes):
size:>50000 
size:<10000 

Search by dependency name/version:
dependency:log4j 
dependency:log4j=1.0.0 
dependency:log4j>1.0.0 

Search by uploaded date:
uploaded:>"1 day ago" 
uploaded:<"August 14, 2022 EST" 

Search by entitlement token (identifier):
entitlement:3lKPVJPosCsY 

Search by policy violation:
policy_violated:true
deny_policy_violated:true
license_policy_violated:true
vulnerability_policy_violated:true

Search by repository:
repository:repo-name

Search queries for all Debian-specific (and related) package types

Search by component:
deb_component:unstable

Search queries for all Maven-specific (and related) package types

Search by group ID:
maven_group_id:org.apache

Search queries for all Docker-specific (and related) package types

Search by image digest:
docker_image_digest:sha256:7c5..6d4
(full hashref only)

Search by layer digest:
docker_layer_digest:sha256:4c4..ae4
(full hashref only)

Field type modifiers (depending on the type, you can influence behaviour)

For all queries, you can use:
~foo for negation

For string queries, you can use:
^foo to anchor to start of term
foo$ to anchor to end of term
foo*bar for fuzzy matching

For number/date or version queries, you can use:
>foo for values greater than
>=foo for values greater / equal
<foo for values less than
<=foo for values less / equal

Need a secure and centralised artifact repository to deliver Alpine, Cargo, CocoaPods, Composer, Conan, Conda, CRAN, Dart, Debian, Docker, Go, Helm, Hex, LuaRocks, Maven, npm, NuGet, P2, Python, RedHat, Ruby, Swift, Terraform, Vagrant, Raw & More packages?

Cloudsmith is the new standard in Package / Artifact Management and Software Distribution.

With support for all major package formats, you can trust us to manage your software supply chain.

Start My Free Trial

Helm logo caliper  0.1.7

One-liner (summary)

Caliper helm chart for Rollups programmability benchmarking

Description

Same as above (description was repeated).

License

Unknown

Size

5.4 KB

Downloads

573

Tags

chart tgz latest

Status  Completed
Checksum (MD5) 5d1eed8c0938ca5f2220c7fb529eb82c
Checksum (SHA-1) b76b0c7a1e2ad1979e5d88a0b1c1dba1006ebb2c
Checksum (SHA-256) 9e76104ddabc4f61db6c159403fbe8c25273438fb6dfedd86351aeb44874c80b
Checksum (SHA-512) 3241671ff468dd0afa1d605fd2cd24efbeb8a5538ae7192f54d8d9d3c6023d32f4…
GPG Signature
Storage Region  Dublin, Ireland
Type  Binary (contains binaries and binary artifacts)
Uploaded At 1 year, 9 months ago
Uploaded By Fetched by Cloudsmith
Slug Id caliper-017tgz-dZO
Unique Id vtVpYWKSnVgV
Version (Raw) 0.1.7
Version (Parsed)
  • Major: 0
  • Minor: 1
  • Patch: 7
  • Type: SemVer (Strict)
  extended metadata
App Version 0.0.0
pkg caliper-0.1.7.tgz 573
5.4 KB
md5 sha1 sha256 sha512
Package Contents (caliper-0.1.7.tgz)
Loading...

This package has 11 files/directories.

Loading...

You can embed a badge in another website that shows this or the latest version of this package.

To embed the badge for this specific package version, use the following:

[![This version of 'caliper' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/consensys/helm/helm/caliper/0.1.7/x/?render=true)](https://cloudsmith.io/~consensys/repos/helm/packages/detail/helm/caliper/0.1.7/)
|This version of 'caliper' @ Cloudsmith|
.. |This version of 'caliper' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/consensys/helm/helm/caliper/0.1.7/x/?render=true
   :target: https://cloudsmith.io/~consensys/repos/helm/packages/detail/helm/caliper/0.1.7/
image::https://api-prd.cloudsmith.io/v1/badges/version/consensys/helm/helm/caliper/0.1.7/x/?render=true[link="https://cloudsmith.io/~consensys/repos/helm/packages/detail/helm/caliper/0.1.7/",title="This version of 'caliper' @ Cloudsmith"]
<a href="https://cloudsmith.io/~consensys/repos/helm/packages/detail/helm/caliper/0.1.7/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/consensys/helm/helm/caliper/0.1.7/x/?render=true" alt="This version of 'caliper' @ Cloudsmith" /></a>

rendered as: This version of 'caliper' @ Cloudsmith

To embed the badge for the latest package version, use the following:

[![Latest version of 'caliper' @ Cloudsmith](https://api-prd.cloudsmith.io/v1/badges/version/consensys/helm/helm/caliper/latest/x/?render=true&show_latest=true)](https://cloudsmith.io/~consensys/repos/helm/packages/detail/helm/caliper/latest/)
|Latest version of 'caliper' @ Cloudsmith|
.. |Latest version of 'caliper' @ Cloudsmith| image:: https://api-prd.cloudsmith.io/v1/badges/version/consensys/helm/helm/caliper/latest/x/?render=true&show_latest=true
   :target: https://cloudsmith.io/~consensys/repos/helm/packages/detail/helm/caliper/latest/
image::https://api-prd.cloudsmith.io/v1/badges/version/consensys/helm/helm/caliper/latest/x/?render=true&show_latest=true[link="https://cloudsmith.io/~consensys/repos/helm/packages/detail/helm/caliper/latest/",title="Latest version of 'caliper' @ Cloudsmith"]
<a href="https://cloudsmith.io/~consensys/repos/helm/packages/detail/helm/caliper/latest/"><img src="https://api-prd.cloudsmith.io/v1/badges/version/consensys/helm/helm/caliper/latest/x/?render=true&show_latest=true" alt="Latest version of 'caliper' @ Cloudsmith" /></a>

rendered as: Latest version of 'caliper' @ Cloudsmith

These instructions assume you have setup the repository first (or read it).

To install/use caliper @ version 0.1.7 ...

helm install consensys-helm/caliper --version 0.1.7

You can also install the latest version of this chart:

helm install consensys-helm/caliper

Or you can upgrade to the most recent version of this chart if you've already installed:

helm upgrade consensys-helm/caliper

If necessary, you can specify the repository directly:

helm install caliper \
  --repo 'https://artifacts.consensys.net/public/helm/helm/charts/'

If you've got a requirements.yaml file in your chart, you can specify this as a dependency:

dependencies:
  - name: caliper
    version: 0.1.7
    repository: https://artifacts.consensys.net/public/helm/helm/charts/
Top